温馨提醒

如果文章内容或图片资源失效,请留言反馈,我们会及时处理,谢谢!

本文最后更新于2024年1月21日,已超过 30天没有更新

在对帝国CMS进行升级之后,PHP使用7.4之后会出现类似的错误,如下代码所示:

Deprecated: Function get_magic_quotes_gpc() is deprecated in /www/wwwroot/www.123.cn/e/class/connect.php on line 9

这是因为你现在的PHP版本太高了,当然,帝国CMS7.5在最初升级的时候是支持PHP7的,但那个时候PHP也就到了7这个版本,PHP7之后的版本又有较大的变化,所以出现了部分不兼容的情况,但都是小问题,跟我操作吧:

  • 进入到帝国的根目录,然后找到e目录
  • 然后再进入到class目录
  • 找到connect.php文件,用编辑器打开它
  • Ctrl + F高亮找到define(‘MAGIC_QUOTES_GPC’语句
  • 然后将其改为
define('MAGIC_QUOTES_GPC',ini_set("magic_quotes_runtime",0)?True:False);
  • 保存之后,就可以正常使用了
版权声明:原创作品,未经允许不得转载,否则将追究法律责任。
本站资源有的自互联网收集整理,如果侵犯了您的合法权益,请联系本站我们会及时删除。
本站资源仅供研究、学习交流之用,若使用商业用途,请购买正版授权,否则产生的一切后果将由下载用户自行承担。
本文链接:悟空资源网https://www.wkzyw.com/89249.html
许可协议:《署名-非商业性使用-相同方式共享 4.0 国际 (CC BY-NC-SA 4.0)》许可协议授权